Some Solana Mainnet Nodes Behind Head of Chain

Incident Report for Validation Cloud Node API

Resolved

This incident has been resolved.
Posted May 29, 2026 - 14:19 UTC

Identified

We've observed some Solana Mainnet RPC nodes falling behind. Those nodes are being worked on to bring them back to head of the chain.

Some latest slot requests may fail.
Posted May 29, 2026 - 12:45 UTC
This incident affected: Solana (Solana - Mainnet).