Stellar Pubnet Soroban RPC outage

Incident Report for Validation Cloud Node API

Resolved

This incident has been resolved.
Posted Feb 21, 2026 - 03:46 UTC

Investigating

Network-wide issues impacting Soroban RPC service.
Posted Feb 20, 2026 - 20:54 UTC
This incident affected: Stellar (Stellar - Pubnet - Horizon + RPC).